Erik,

Just wanted to run this by you but I wanted to do this awhile ago, the writeToken() method's original intention was to pass the token to write and automatically append a space AFTER the token.

So writeToken(ASTokens.SET);

Will produce;

'set '

This way when ever we have a token, the rule is tokens Always have a space to the right. This will eliminate a hug amount of code and make things more readable.


Since we put it in some places, before this change happens either you or I have to do all of it and make sure the tests pass because whitespace will get changed on the writeToken() calls right now.

I'm thinking ASTokens should be an enum and we pass the enum to writeToken() for type safety. What do you think?

Mike



--
Michael Schmalle - Teoti Graphix, LLC
http://www.teotigraphix.com
http://blog.teotigraphix.com

Reply via email to