Harbs,

This is my proposition for naming - taken from C# Dictionary:

delete -> Remove(key)
get -> GetValue(key) 
set -> Add(key, value)
has(key) -> ContainsKey(key)
I see that there is no method for checking whether value exists, maybe it is
an good opportunity to have it: ContainsValue(value)
clear() - I would leave as is.

In my opinion also those methods should be same for COMPILE::SWF and
COMPILE::JS - even if we are not reflecting JS API. I wanted to be as far as
we can from JS naming world. :)

What do you think ?

Piotr 



-----
Apache Flex PMC
piotrzarzyck...@gmail.com
--
View this message in context: 
http://apache-flex-development.2333347.n4.nabble.com/FlexJS-maven-faling-WeakMap-tp59270p59414.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

Reply via email to