Hi all, We are dealing with some streams with large (nested) schemas. When using `t ableEnv.createTemporaryView()` to register a DataStream to a table, the transformation always gets a large name. It's not a big problem, but quite annoying since the UI and logs are hard to read.
Internally, `ExternalDynamicSource` (and `ExternalDynamicSink`) invokes `physicalDataType.toString()` to generate an operator name (which will also be used as the transformation name). I'm thinking to introduce a new table config to either truncate the name or use a limited level of logicalType to generate the name (works for nested schemas). What do you think? Best, Xingcan