Tristan Stevens commented on FLUME-2698:

I've had a go at this today and posted a patch to the review board at 
Grateful for any feedback and/or alpha testin. [~abij] I've included (but not 
yet documented) the ability to run multi-threaded and also to configure the 
queue sizes etc. It would be good to see whether this improves your performance 

> Upgrade Jetty Version
> ---------------------
>                 Key: FLUME-2698
>                 URL: https://issues.apache.org/jira/browse/FLUME-2698
>             Project: Flume
>          Issue Type: Bug
>          Components: Web
>    Affects Versions: v1.6.0, v1.5.1, v1.7.0
>            Reporter: Joakim Erdfelt
>            Assignee: Tristan Stevens
> Flume depends on Jetty 6
> {code:xml}
>       <dependency>
>         <groupId>org.mortbay.jetty</groupId>
>         <artifactId>jetty-util</artifactId>
>         <version>6.1.26</version>
>       </dependency>
> {code}
> Which was EOL (End of Life) back in 2010 and is no longer fit for production 
> use (without heavy customizations and modifications like Google does for GAE, 
> just to keep it safe and vulnerability free)
> Jetty was moved to Eclipse.org back during the Jetty 7 days.
> http://eclipse.org/jetty/
> Note that [Jetty 7 and Jetty 8 are now also 
> EOL|https://dev.eclipse.org/mhonarc/lists/jetty-announce/msg00069.html] (as 
> of 2014)
> Jetty 9 is the only stable and supported version of Jetty now.

This message was sent by Atlassian JIRA

Reply via email to