[ 
https://issues.apache.org/jira/browse/FLUME-1520?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16094497#comment-16094497
 ] 

Attila Simon commented on FLUME-1520:
-------------------------------------

Hi [~tmgstev],

The 2nd patch contains an extra file. I guess it was added by mistake: 
flume-ng-core/src/main/java/org/apache/flume/interceptor/TimestampInterceptor.java.orig
Unfortunately the patch fails maven build on checkstyle. 

Overall the doc, test and functionality looks good to me. 
I'm only nitpicking on the naming:
{code}
public class TimestampInterceptor implements Interceptor {
    private final String header;
...
  public static class Constants {
    public static final String CONFIG_PRESERVE = "preserveExisting";
    public static final boolean DEFAULT_PRESERVE = false;
    public static final String CONFIG_HEADER_NAME = "headerName";
    public static final String DEFAULT_HEADER_NAME = "timestamp";
  }
{code}

I have this renaming and using final for constants as well as removed some 
unused local variables from the tests. I upload a patch which compiles and 
passes junit as well. Please feel free to use it (completely or parts) if you 
like.


> Timestamp interceptor should support custom headers
> ---------------------------------------------------
>
>                 Key: FLUME-1520
>                 URL: https://issues.apache.org/jira/browse/FLUME-1520
>             Project: Flume
>          Issue Type: Improvement
>            Reporter: Hari Shreedharan
>            Assignee: Hari Shreedharan
>             Fix For: 1.8.0
>
>         Attachments: FLUME-1520-2.patch, FLUME-1520-3.patch, FLUME-1520.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to