I have few comments:

1, What is ClusterElement/RegionElement interfaces used for?

2. I see that using unary mutator one can mutate both cache and region
configurations, so the methods in ClusterConfigurationService can be
getClusterConfig and updateClusterConfig? The naming is debatable as region
configuration is part of CacheConfig, so technically user is updating
CacheConfig even for region changes and changing a group's configuration is
not cluster configuration. So I think updateCacheConfig is a better name
than updateClusterConfig?

On Mon, Mar 12, 2018 at 4:11 PM, Patrick Rhomberg <prhomb...@pivotal.io>

> Hello all.
>   Please refer to the wiki page [1] for a proposal to expose modification
> of cluster configuration.
>   In short, this proposes an endpoint for developers to modify or extend
> cluster configuration functionalities.  This would eventually replace
> existing configuration classes (e.g., CacheCreation).
>   The proposed intends to use JAXB to generate and translate between Java
> Objects and the underlying cache configuration's XML.  Examples of these
> generated classes are included in the proposal's Resources section.
>   Regards.
> Imagination is Change.
> ~Patrick
> [1]
> https://cwiki.apache.org/confluence/display/GEODE/Public+API+for+Cluster+
> Configuration

Reply via email to