[ http://issues.apache.org/jira/browse/GERONIMO-2006?page=all ]
Erin Mulder updated GERONIMO-2006:
----------------------------------
Fix Version: 1.1
Assign To: Aaron Mulder
While trying to reproduce this, I discovered different behavior in Tomcat vs.
Jetty, and in web console vs. command-line deployer. It also seems that there
are several different underlying bugs.
Tomcat, Web Console Deployer:
1. Deploying the attached files as they are (without changing configId to
moduleId) caused stack trace and blank web page
2. After replacing configId with moduleId in badPlan.xml, I got messages about
how the app had deployed and started successfully, despite the fact that it
hadn't. However, it didn't break Web App WARs page, so I could uninstall it
easily.
3. When I tried deploying it again without uninstalling first, I got a stack
trace in the portlet window instead of a normal error message.
4. Deploying with badPlan2.xml caused stack trace in portlet window instead of
error message, but didn't result in a deployment or half-deployment.
Jetty, Web Console Deployer
1. Deploying with badPlan.xml causes stack traces to STDOUT, but no indication
of error to user. Portlet just redisplays. App is not deployed.
2. Same result after changing "configId" to "moduleId" in plan.
3. Deploying with badPlan2.xml causes stack traces to STDOUT and blank web page.
Jetty, Command-Line Deployer
1. Descriptive errors produced on all bad plans
Tomcat, Command-Line Deployer
1. badPlan.xml causes descriptive error
2. badPlan.xml with moduleId fix causes stack trace during start
3. badPlan2.xml causes descriptive error
> Deploying an application with an incorrect deployment plan results in
> non-functional admin console panel
> --------------------------------------------------------------------------------------------------------
>
> Key: GERONIMO-2006
> URL: http://issues.apache.org/jira/browse/GERONIMO-2006
> Project: Geronimo
> Type: Bug
> Security: public(Regular issues)
> Components: console
> Versions: 1.1
> Reporter: Dave Colasurdo
> Assignee: Aaron Mulder
> Fix For: 1.1
> Attachments: Myapp.war, badPlan.xml, badPlan2.xml, stackTrace.log
>
> Deploying myApp.war using badPlan.xml (both attached) results in a
> non-functioning "Show Web App Wars" panel.
> The console "Deploy Applications" panel reports "application installed and
> started successfully". However, the application did not startup succesfully.
> The badPlan file is actually missing tcpListenerAddress=auto which causes
> TomcatReceiver Gbean to fail startup. I've attached the stacktrace to the
> JIRA.
> From then on, the "Web App Wars" console panel shows "portlet error" and
> there is no way to uninstall the bad application via the console. The server
> must be stopped and restarted in order to have the "Web App War" panel
> function correctly.
> The console should be able to report the true status of the "deploy/start"
> and recover from deploying a bad plan.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira