[
https://issues.apache.org/jira/browse/GERONIMO-3229?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Donald Woods resolved GERONIMO-3229.
------------------------------------
Resolution: Fixed
Committed revision 545376 in trunk.
YunFeng, thanks for the patch and please close this when you have verified the
updated server code.
> Missing environment variable java.rmi.server.RMIClassLoaderSpi for Deployer
> ---------------------------------------------------------------------------
>
> Key: GERONIMO-3229
> URL: https://issues.apache.org/jira/browse/GERONIMO-3229
> Project: Geronimo
> Issue Type: Bug
> Security Level: public(Regular issues)
> Components: deployment
> Affects Versions: 2.0-M6
> Environment: Windows
> Reporter: YunFeng Ma
> Assignee: Donald Woods
> Fix For: 2.0-M7
>
> Attachments: GERONIMO-3229.patch
>
>
> We have set environment variable
> java.rmi.server.RMIClassLoaderSpi=org.apache.geronimo.kernel.rmi.RMIClassLoaderSpiImpl
> when geronimo server startup, but didn't set for deployer. If geronimo is
> installed under a directory in which there is a space, such as C:\Program
> Files\Apache Software Foundation\geronimo, the deployer doesn't work well.
> The following steps will show this error.
> 1. deploy deploy f:\temp\hello-2.0-SNAPSHOT.war
> 2. deploy deploy f:\temp\hello-2.0-SNAPSHOT.war
> This time will get the following message:
> Error: Unable to distribute hello-2.0-SNAPSHOT.war: Error
> unmarshaling return; nested exception is:
> java.net.MalformedURLException: no protocol: Files/Apache
> no protocol: Files/Apache
> instead of:
> Error: Unable to distribute hello-2.0-SNAPSHOT.war:
> org.apache.geronimo.kernel.config.ConfigurationAlreadyExistsException:
> Configuration already exists: samples/hello/2.0/war
> Configuration already exists: samples/hello/2.0/war
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.