Alex Osborne created HTTPASYNC-140:
--------------------------------------

             Summary: HttpAsyncClientBuilder misnamed interceptor methods
                 Key: HTTPASYNC-140
                 URL: https://issues.apache.org/jira/browse/HTTPASYNC-140
             Project: HttpComponents HttpAsyncClient
          Issue Type: Bug
         Environment: Affects both httpclient 5.0-beta1 and git master at the 
time of writing.
            Reporter: Alex Osborne


These two methods on HttpAsyncClientBuilder appear to have had the words 
'Request' and Response' swapped in their names as they actually take a 
parameter of the opposite type:
{code:java}
addRequestInterceptorFirst(HttpResponseInterceptor interceptor)
addResponseInterceptorLast(HttpRequestInterceptor interceptor){code}
the other two interceptor methods seem to be named correctly:
{code:java}
addRequestInterceptorFirst(HttpRequestInterceptor interceptor)
addResponseInterceptorLast(HttpResponseInterceptor interceptor)
{code}
 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to