arturobernalg opened a new pull request, #897:
URL: https://github.com/apache/httpcomponents-client/pull/897

   This change tightens SCRAM-SHA-256 validation for the initial authentication 
exchange according to RFC 5802, RFC 7677 and RFC 7804.
   
   It adds stricter validation of SCRAM message structure and attributes, 
canonical Base64 encoding, strict UTF-8 decoding, duplicate parameter 
detection, and RFC-compliant handling of password preparation.


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to