The Apache HttpComponents project is pleased to announce 5.5-beta4 release of HttpComponents Core.
This BETA release features multiple HTTP/2 protocol conformance improvements and performance optimizations, introduces support for Digest Fields (RFC 9530), and improves async IOsession pool functionality. It is expected to be the last BETA release before 5.5 GA. This release includes all fixes from the stable 5.4 branch. Notable changes and features included in the 5.5 series: * Improved connection pool implementation. * Added HTTP message stream APIs and support for HTTP/2 message stream timeouts. * Updated SSLContexts to respect system properties by default. * Limited pending HTTP/2 request commands per connection. * Improved conformance with RFC 7540, HPACK (RFC 7541), and HTTP/2 (RFC 9113). * Building HttpCore with Maven now requires Java 17 or newer. Published artifacts remain compatible with Java 8. * Added support for the QUERY method (RFC 10008). * Added support for Structured Field Values for HTTP (RFC 9651). * Added support for Digest Fields (RFC 9530). * Improved async IOSession pool implementation. Compatibility notes: * HTTP requesters and servers respect SSL/TLS system properties by default. * Building HttpCore with Maven now requires Java 17 or newer. Published artifacts remain compatible with Java 8. Download - <http://hc.apache.org/downloads.cgi> Release notes - <http://www.apache.org/dist/httpcomponents/httpcore/RELEASE_NOTES-5.5.x.txt HttpComponents site - <http://hc.apache.org/> About HttpComponents Core HttpCore is a set of low level HTTP transport components that can be used to build custom client and server side HTTP services with a minimal footprint. HttpCore supports two I/O models: a blocking I/O model based on the classic Java I/O and a non-blocking, event driven I/O model based on Java NIO --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
