-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38663/#review100268
-----------------------------------------------------------



contrib/src/java/org/apache/hadoop/hive/contrib/classloader/ClassA.java (line 1)
<https://reviews.apache.org/r/38663/#comment157420>

    Since this is test code I think it would be good to create a new 
"custom-udfs" module (with several submodules) in the itest module and move the 
code there. There are several qfile tests that show how to access itest modules 
in the local cache (e.g. alter1.q). It's also possible that we can access them 
more succinctly using the ivy:// notation.



ql/src/java/org/apache/hadoop/hive/ql/exec/UDFClassLoader.java (line 26)
<https://reviews.apache.org/r/38663/#comment157421>

    Please add a comment that explains why it's necessary to modify the 
URLClassLoader.



ql/src/test/queries/clientpositive/test_classloader.q (line 1)
<https://reviews.apache.org/r/38663/#comment157422>

    Change the name to "udf_classloader.q"
    
    Is it possible to test the ivy:// codepath as well? I realize that right 
now there shouldn't be much difference, but who knows what changes people will 
make in the future...


- Carl Steinbach


On Sept. 23, 2015, 5:38 a.m., Ratandeep Ratti wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38663/
> -----------------------------------------------------------
> 
> (Updated Sept. 23, 2015, 5:38 a.m.)
> 
> 
> Review request for hive.
> 
> 
> Bugs: HIVE-11878
>     https://issues.apache.org/jira/browse/HIVE-11878
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> HIVE-11878: ClassNotFoundException can possibly occur if multiple jars are 
> registered one at a time in Hive
> 
> 
> Diffs
> -----
> 
>   contrib/src/java/org/apache/hadoop/hive/contrib/classloader/ClassA.java 
> PRE-CREATION 
>   contrib/src/java/org/apache/hadoop/hive/contrib/classloader/UDF1.java 
> PRE-CREATION 
>   contrib/src/java/org/apache/hadoop/hive/contrib/classloader/UDF2.java 
> PRE-CREATION 
>   itests/pom.xml acce7131948edd5aeab34af6879d781daa12ba30 
>   itests/qtest/pom.xml 0588233b250f7c78f594bb36554a80990e907550 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/UDFClassLoader.java PRE-CREATION 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java 
> ca863019f3347c94852dcad2a21c43758aed30a7 
>   ql/src/test/queries/clientpositive/test_classloader.q PRE-CREATION 
>   ql/src/test/results/clientpositive/test_classloader.q.out PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/38663/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Ratandeep Ratti
> 
>

Reply via email to