----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/43176/#review117816 -----------------------------------------------------------
ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java (line 129) <https://reviews.apache.org/r/43176/#comment179081> two nested try-catch block seem making the code hard to read. ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java (line 135) <https://reviews.apache.org/r/43176/#comment179079> Should we check if it's a directory before calling listStatus() on it? ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java (line 144) <https://reviews.apache.org/r/43176/#comment179080> Instead of doing this, should we explicitly check the existance of the destination? On a high level, deleting file one by one is slower. Could we instead remember the original permission and set it to the new directory that we are going to replace? - Xuefu Zhang On Feb. 4, 2016, 4:07 a.m., Chaoyu Tang wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/43176/ > ----------------------------------------------------------- > > (Updated Feb. 4, 2016, 4:07 a.m.) > > > Review request for hive, Ashutosh Chauhan, Szehon Ho, and Xuefu Zhang. > > > Bugs: HIVE-12965 > https://issues.apache.org/jira/browse/HIVE-12965 > > > Repository: hive-git > > > Description > ------- > > In Hive, "insert overwrite local directory" first deletes the overwritten > directory if exists, recreate a new one, then copy the files from src > directory to the new local directory. This process sometimes changes the > permissions of the to-be-overwritten local directory, therefore causing some > applications no more to be able to access its content. > > > Diffs > ----- > > ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java e9cd450 > > Diff: https://reviews.apache.org/r/43176/diff/ > > > Testing > ------- > > Manual tests > Precommit tests > > > Thanks, > > Chaoyu Tang > >