-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/50073/#review142420
-----------------------------------------------------------



LGTM. Few minor comments.


common/src/java/org/apache/hadoop/hive/common/FileUtils.java (line 866)
<https://reviews.apache.org/r/50073/#comment207984>

    It'd be great to document this default assumption in the 
HiveConf.HIVEAUXJARS config description.



common/src/test/org/apache/hadoop/hive/common/TestFileUtils.java (lines 21 - 22)
<https://reviews.apache.org/r/50073/#comment207975>

    nit: extra lines



common/src/test/org/apache/hadoop/hive/common/TestFileUtils.java (line 42)
<https://reviews.apache.org/r/50073/#comment207973>

    nit: rename f -> tmpDir for readability



common/src/test/org/apache/hadoop/hive/common/TestFileUtils.java (line 45)
<https://reviews.apache.org/r/50073/#comment207974>

    nit: rename to jarFile1



ql/src/java/org/apache/hadoop/hive/ql/exec/spark/LocalHiveSparkClient.java 
(line 156)
<https://reviews.apache.org/r/50073/#comment207977>

    To be safe:
    SessionState.get() == null ? null : 
SessionState.get().getReloadableAuxJars(); ?



ql/src/java/org/apache/hadoop/hive/ql/exec/spark/RemoteHiveSparkClient.java 
(line 215)
<https://reviews.apache.org/r/50073/#comment207983>

    To be safe:
    SessionState.get() == null ? null : 
SessionState.get().getReloadableAuxJars(); ?


- Mohit Sabharwal


On July 15, 2016, 11:07 a.m., Aihua Xu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/50073/
> -----------------------------------------------------------
> 
> (Updated July 15, 2016, 11:07 a.m.)
> 
> 
> Review request for hive.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> HIVE-14198: Refactor aux jar related code to make them more consistency
> 
> 
> Diffs
> -----
> 
>   common/src/java/org/apache/hadoop/hive/common/FileUtils.java 
> d755798e341651422aedcfead84d0af69b314734 
>   common/src/java/org/apache/hadoop/hive/conf/HiveConf.java 
> 42f7d8829211e34e25e7a9e45657220cd648cc61 
>   common/src/test/org/apache/hadoop/hive/common/TestFileUtils.java 
> PRE-CREATION 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java 
> 973bc23fb7fef833b33aaaea26901d7cdd8d6598 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/spark/LocalHiveSparkClient.java 
> 0c0fe9513925beadea9c530e5dc79a332454397f 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/spark/RemoteHiveSparkClient.java 
> 2b06a04907cec5b8dce72db169127eef21ba4b7d 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/spark/SparkUtilities.java 
> 5a6bef96480a34af236074dda554920dd1757796 
>   ql/src/java/org/apache/hadoop/hive/ql/session/SessionState.java 
> f983b820429fba531e1b3158c8f58ed1a1c12800 
>   ql/src/test/org/apache/hadoop/hive/ql/exec/TestUtilities.java 
> 69f54651746e80a01401a6de723fac5c751f425b 
> 
> Diff: https://reviews.apache.org/r/50073/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Aihua Xu
> 
>

Reply via email to