----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57620/#review168961 -----------------------------------------------------------
ql/src/java/org/apache/hadoop/hive/ql/exec/NamedJoinInfo.java Lines 19 (patched) <https://reviews.apache.org/r/57620/#comment241295> Should be in o.a.h.h.ql.parse ql/src/java/org/apache/hadoop/hive/ql/exec/NamedJoinInfo.java Lines 24 (patched) <https://reviews.apache.org/r/57620/#comment241292> Add comments. NamedColsInJoin encapsulates information about using clause of join. e.g., select * from a join b using(c); This class describes column c. ql/src/java/org/apache/hadoop/hive/ql/exec/NamedJoinInfo.java Lines 25 (patched) <https://reviews.apache.org/r/57620/#comment241293> Better name: NamedColInJoin. ql/src/java/org/apache/hadoop/hive/ql/exec/NamedJoinInfo.java Lines 26 (patched) <https://reviews.apache.org/r/57620/#comment241294> Better name: tableAliases ql/src/java/org/apache/hadoop/hive/ql/parse/CalcitePlanner.java Lines 1929 (patched) <https://reviews.apache.org/r/57620/#comment241296> Comment: We will transform using clause and make it look like an on-clause. So, lets generate a valid on-clause AST from using. ql/src/java/org/apache/hadoop/hive/ql/parse/CalcitePlanner.java Lines 1949 (patched) <https://reviews.apache.org/r/57620/#comment241297> Error message: Atleast one column is expected in using() Found: 0. ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java Lines 3432 (patched) <https://reviews.apache.org/r/57620/#comment241298> Comment: We got using() clause in previous join. Need to generate select list as per standard. For * we will have joining columns first non-repeated followed by other columns. ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java Lines 3490 (patched) <https://reviews.apache.org/r/57620/#comment241299> Remove this comment. Its misplaced since named columns will not be always there at this point. ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java Lines 3501 (patched) <https://reviews.apache.org/r/57620/#comment241300> Comment: we already added this column in select list. ql/src/test/queries/clientpositive/named_column_join.q Lines 29 (patched) <https://reviews.apache.org/r/57620/#comment241301> Test for 3-way join: select * from (select t1.b b from t t1 inner join t t2 using (b)) t3 join t t4 using(b); select * from (select t2.a a from t t1 inner join t t2 using (b)) t3 join t t4 using(a); - Ashutosh Chauhan On March 14, 2017, 8:43 p.m., pengcheng xiong wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/57620/ > ----------------------------------------------------------- > > (Updated March 14, 2017, 8:43 p.m.) > > > Review request for hive and Ashutosh Chauhan. > > > Repository: hive-git > > > Description > ------- > > HIVE-15983 > > > Diffs > ----- > > ql/src/java/org/apache/hadoop/hive/ql/exec/NamedJoinInfo.java PRE-CREATION > ql/src/java/org/apache/hadoop/hive/ql/parse/CalcitePlanner.java bf0a11b > ql/src/java/org/apache/hadoop/hive/ql/parse/FromClauseParser.g 558ca7f > ql/src/java/org/apache/hadoop/hive/ql/parse/RowResolver.java e14f1cf > ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java 0732207 > ql/src/test/queries/clientpositive/named_column_join.q PRE-CREATION > ql/src/test/results/clientpositive/named_column_join.q.out PRE-CREATION > > > Diff: https://reviews.apache.org/r/57620/diff/1/ > > > Testing > ------- > > > Thanks, > > pengcheng xiong > >