Dear all,

Sorry if this is not the right communication channel for this type of question 
but I am a bit stuck.
I am trying to import Apache Hive into eclipse using the Apache Hive developers 

In my eclipse workspace, I cloned the github repository.
I removed the .m2/repository/org/apache/hive folder.
I executed the described maven command: "mvn clean package eclipse:clean 
eclipse:eclipse -Pitests -DskipTests -DdownloadSources -DdownloadJavadocs".
Then I tried to import the project into the workspace first as an existing 
maven project from the root folder and when that did not work I tried it as an 
existing project which also did not work.

Running maven install to try and resolve the issues in eclipse fails because of 
failing tests in the hive query language project. Upon further inspection it 
seems to fail because hadoop_home and hadoop.home.dir are unset at 
However, hadoop_home is set in my path (version 3.1.1).

Again, I'm sorry if this is not the right place for these types of questions. I 
am a bit new to hive (and hadoop in general) but I would greatly appreciate it 
if someone can recognize what I did wrong and what I can do to resolve it.

With kind regards,


Reply via email to