mahesh kumar behera created HIVE-22234:
------------------------------------------
Summary: Hive replication fails with table already exist error
when replicating from old version of hive.
Key: HIVE-22234
URL: https://issues.apache.org/jira/browse/HIVE-22234
Project: Hive
Issue Type: Bug
Reporter: mahesh kumar behera
Assignee: mahesh kumar behera
HIve replication from old version where HIVE-22046 is not patched will not have
engine column set in the table column stats. This causes "ERROR: null value in
column "ENGINE" violates not-null constraint" error during create table while
updating the column stats. As the column stats are updated after the create
table txn is committed, the next retry by HMS client throws table already exist
error. Need to update the ENGINE column to default value while importing the
table if the column value is not set. The column stat and create table in same
txn can be done as part of separate Jira.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)