David Mollitor created HIVE-23017:
-------------------------------------
Summary: Remove Superfluous 'Transient' Keyword From FetchTask
Key: HIVE-23017
URL: https://issues.apache.org/jira/browse/HIVE-23017
Project: Hive
Issue Type: Improvement
Reporter: David Mollitor
{code:java|title=FetchTask}
public class FetchTask extends Task<FetchWork> implements Serializable {
private static final long serialVersionUID = 1L;
private int maxRows = 100;
private FetchOperator fetch;
private ListSinkOperator sink;
private int totalRows;
private static transient final Logger LOG =
LoggerFactory.getLogger(FetchTask.class);
JobConf job = null;
{code}
There is not need for this {{Logger}} to be transient. Please remove as it is
useless overheard.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)