[ 
https://issues.apache.org/jira/browse/HIVE-5413?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Eugene Koifman updated HIVE-5413:
---------------------------------

    Description: 
org.apache.hive.hcatalog.security.StorageDelegationAuthorizationProvider
has a block like this:

  static {
    registerAuthProvider("org.apache.hadoop.hive.hbase.HBaseStorageHandler",
      "org.apache.hive.hcatalog.hbase.HBaseAuthorizationProvider");
    
registerAuthProvider("org.apache.hive.hcatalog.hbase.HBaseHCatStorageHandler",
      "org.apache.hive.hcatalog.hbase.HBaseAuthorizationProvider");
  }


In reality, HBaseHCatStorageHandler and HBaseAuthorizationProvider only exist 
in org.apache.hcatalog

This should be fixed.  Also, should use Foo.class.getName() instead of strings 
to make this a compile time check


Also,
hcatalog/src/test/e2e/hcatalog/tests/pig.conf & hadoop.conf have the same 
problem.  
In addition, the tests affected in pig.conf/hadoop.conf should use 
org.apache.hcatalog.pig.HCatLoader/HCatStorer.

Finally, hadoop.conf#Hadoop_HBase is using 
org.apache.hive.hcatalog.utils.HBaseReadWrite which internally refers to 
org.apache.hive.hcatalog.* classes.  The later should only use 
org.apache.hcatalog.* since it's using HBaseHCatStoreageHandler.  Also, should 
move HBaseReadWrite to org.apache.hcatalog for clarity.
(see the last paragraph of the Description of HIVE-5274)




  was:
org.apache.hive.hcatalog.security.StorageDelegationAuthorizationProvider
has a block like this:

  static {
    registerAuthProvider("org.apache.hadoop.hive.hbase.HBaseStorageHandler",
      "org.apache.hive.hcatalog.hbase.HBaseAuthorizationProvider");
    
registerAuthProvider("org.apache.hive.hcatalog.hbase.HBaseHCatStorageHandler",
      "org.apache.hive.hcatalog.hbase.HBaseAuthorizationProvider");
  }


In reality, HBaseHCatStorageHandler and HBaseAuthorizationProvider only exist 
in org.apache.hcatalog

This should be fixed.  Also, should use Foo.class.getName() instead of strings 
to make this a compile time check


> StorageDelegationAuthorizationProvider uses non-existent 
> org.apache.hive.hcatalog.hbase.HBaseHCatStorageHandler
> ---------------------------------------------------------------------------------------------------------------
>
>                 Key: HIVE-5413
>                 URL: https://issues.apache.org/jira/browse/HIVE-5413
>             Project: Hive
>          Issue Type: Bug
>          Components: HCatalog
>    Affects Versions: 0.12.0
>            Reporter: Eugene Koifman
>            Assignee: Eugene Koifman
>             Fix For: 0.12.0
>
>
> org.apache.hive.hcatalog.security.StorageDelegationAuthorizationProvider
> has a block like this:
>   static {
>     registerAuthProvider("org.apache.hadoop.hive.hbase.HBaseStorageHandler",
>       "org.apache.hive.hcatalog.hbase.HBaseAuthorizationProvider");
>     
> registerAuthProvider("org.apache.hive.hcatalog.hbase.HBaseHCatStorageHandler",
>       "org.apache.hive.hcatalog.hbase.HBaseAuthorizationProvider");
>   }
> In reality, HBaseHCatStorageHandler and HBaseAuthorizationProvider only exist 
> in org.apache.hcatalog
> This should be fixed.  Also, should use Foo.class.getName() instead of 
> strings to make this a compile time check
> Also,
> hcatalog/src/test/e2e/hcatalog/tests/pig.conf & hadoop.conf have the same 
> problem.  
> In addition, the tests affected in pig.conf/hadoop.conf should use 
> org.apache.hcatalog.pig.HCatLoader/HCatStorer.
> Finally, hadoop.conf#Hadoop_HBase is using 
> org.apache.hive.hcatalog.utils.HBaseReadWrite which internally refers to 
> org.apache.hive.hcatalog.* classes.  The later should only use 
> org.apache.hcatalog.* since it's using HBaseHCatStoreageHandler.  Also, 
> should move HBaseReadWrite to org.apache.hcatalog for clarity.
> (see the last paragraph of the Description of HIVE-5274)



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Reply via email to