Takeshi,

I found that the following *warnings* are occurring in CI.

Could you look into it though It's just a warning?

https://travis-ci.org/apache/incubator-hivemall/jobs/363986771

[WARN] Unable to instrument file
/home/travis/build/apache/incubator-hivemall/spark/spark-2.3/target/generated-classes/cobertura/org/apache/spark/sql/catalyst/expressions/TopKHelper$ScoreWriter.class
java.lang.UnsupportedClassVersionError:
org/apache/spark/sql/catalyst/expressions/codegen/UnsafeRowWriter :
Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method) ~[na:1.7.0_151]
at java.lang.ClassLoader.defineClass(ClassLoader.java:803) ~[na:1.7.0_151]
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
~[na:1.7.0_151]
at java.net.URLClassLoader.defineClass(URLClassLoader.java:442) ~[na:1.7.0_151]
at java.net.URLClassLoader.access$100(URLClassLoader.java:64) ~[na:1.7.0_151]
at java.net.URLClassLoader$1.run(URLClassLoader.java:354) ~[na:1.7.0_151]
at java.net.URLClassLoader$1.run(URLClassLoader.java:348) ~[na:1.7.0_151]
at java.security.AccessController.doPrivileged(Native Method) ~[na:1.7.0_151]
at java.net.URLClassLoader.findClass(URLClassLoader.java:347) ~[na:1.7.0_151]
at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[na:1.7.0_151]
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312) ~[na:1.7.0_151]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[na:1.7.0_151]
at java.lang.Class.forName0(Native Method) ~[na:1.7.0_151]
at java.lang.Class.forName(Class.java:278) ~[na:1.7.0_151]
at org.objectweb.asm.ClassWriter.getCommonSuperClass(Unknown Source)
~[asm-5.0.1.jar:5.0.1]
at


-- 
Makoto YUI <myui AT apache.org>
Research Engineer, Treasure Data, Inc.
http://myui.github.io/

Reply via email to