On 10/04/2005 06:18 PM, [EMAIL PROTECTED] wrote:
> Author: colm
> Date: Tue Oct  4 09:18:24 2005
> New Revision: 294809

[..cut..]

> 
> +
> +AC_CACHE_CHECK([for void pointer length], [ap_void_ptr_lt_long],
> +[AC_TRY_RUN([
> +int main(void)
> +{
> +    return sizeof(void *) < sizeof(long); 
> +}], [ap_void_ptr_lt_long=yes], [ap_void_ptr_lt_long=no], 
> +    [ap_void_ptr_lt_long=no])])
> +
> +if test "$ap_void_ptr_lt_long" = "no"; then
> +    AC_MSG_ERROR([Size of "void *" is less than size of "long"])
> +fi
> +])
> 

[..cut..]

Sorry for being confused by this, but I read your variable name
ap_void_ptr_lt_long as "(size of) void ptr is less than (size of) long",
but the assignment of "yes" and "no" is exactly the opposite. What about

AC_CACHE_CHECK([for void pointer length], [ap_void_ptr_lt_long],
[AC_TRY_RUN([
int main(void)
{
    return sizeof(void *) < sizeof(long);
}], [ap_void_ptr_lt_long=no], [ap_void_ptr_lt_long=yes],
    [ap_void_ptr_lt_long=yes])])

if test "$ap_void_ptr_lt_long" = "yes"; then
    AC_MSG_ERROR([Size of "void *" is less than size of "long"])
fi
])

No functional change, but seems clearer to me.

Regards

Rüdiger



Reply via email to