That feature has been unsupported for over 3 1/2 years. Drop the test.

Bill

On Tue, Nov 21, 2017 at 4:31 PM, Daniel Ruggeri <drugg...@primary.net> wrote:
> Hi, all;
>
> I have only one set of remaining test cases to complete my
> automated-build-and-test-and-report thingamajig. I've identified a
> potential issue with our expected test results and could use a pointer
> from anyone who tests PHP regularly.
>
>
> I'm looking at t/php/safemode.t and according to [1], safemode was
> removed in 5.4.0. The thing I'm wondering is if we should first test for
> PHP <5.4.0 before proceeding or if we should eliminate t/php/safemode.t
> altogether. I'm leaning toward the latter as it's a removed feature and
> shouldn't hold up our own testing.
>
>
> Also, t/php/getlastmod.t fails because of a warning[2] unless php.ini
> has been set to explicitly declare a timezone (unsure of which version
> PHP made this a warning). Should we modify our php script or modify the
> comparison to be a match that includes the month? My workaround was to
> create a php.ini on the fly but we ought to handle this better in the code.
>
>
> Side note... t/filter/case.t fails unless perl documentation is
> installed. We should note this or pick a better file :-)
>
>
> [1] http://php.net/manual/en/features.safe-mode.php
>
> [2] http://php.net/manual/en/function.date.php#refsect1-function.date-errors
>
> --
> Daniel Ruggeri
>

Reply via email to