Oscar Bou commented on ISIS-1489:

Seems there are basically 2 use cases:
- To determine if a property has changed.
- To audit any changes.

Seeing it that way, seems meaningful to consider the first case also an "audit" 
case. So the suggested name seems ok.

> Deprecate @Property(notPersisted=...) and replace with 
> @Property(notAudited=...)
> --------------------------------------------------------------------------------
>                 Key: ISIS-1489
>                 URL: https://issues.apache.org/jira/browse/ISIS-1489
>             Project: Isis
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 1.13.0
>            Reporter: Dan Haywood
>            Assignee: Dan Haywood
>            Priority: Minor
>             Fix For: 1.14.0
> In which case, the attribute should be deprecated, and a new 
> @Property(notAudited=true) be introduced to replace it.
> It's used by:
> - ChangedObjectServiceInternal to determine if a property has changed; 
> marking it as notPersisted means this functionality is skipped.
> - Memento (which you almost certainly don't use, I think is only used in 
> anger by the Wicket viewer).
> It used to be used by the object persistor for persistence-by-reachability 
> (if notPersisted then don't follow the graph), but I *think* that 
> responsibility is now entirely that of JDO/DN.

This message was sent by Atlassian JIRA

Reply via email to