Dan Haywood created ISIS-1548:
---------------------------------
Summary: Allow @Mixin annotation to specify the verb to use for
the action (instead of '$$'); allow '$' to be used as separator.
Key: ISIS-1548
URL: https://issues.apache.org/jira/browse/ISIS-1548
Project: Isis
Issue Type: Improvement
Affects Versions: 1.13.1
Reporter: Dan Haywood
Priority: Minor
Fix For: 1.13.2
The current mixin conventions gives rise to code such as:
{code}
mixin(Invoice._invoice.class, invoice).$$(invoiceDate);
{code}
where:
{code}
public class Invoice {
...
@Mixin
public static class _invoice {
...
public Invoice $$(LocalDate invoiceDate) { ... }
}
}
{code}
We'd like it instead to read:
{code}
mixin(Invoice.invoice.class, invoice).exec(invoiceDate);
{code}
ie, change "$$" to "exec and not require the leading "_" in the mixin name
Suggestion is:
{code}
public class Invoice {
...
@Mixin("exec")
public class invoice {
public void exec(LocalDate invoiceDate) { ... }
}
}
{code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)