[ 
https://issues.apache.org/jira/browse/ISIS-826?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Dan Haywood updated ISIS-826:
-----------------------------
    Summary: Remove WrappedObject interface, use instead WrappingObject as its 
replacement.  (was: WrappedObject interface should use methods that are less 
likely to clash with actual domain object methods)

> Remove WrappedObject interface, use instead WrappingObject as its replacement.
> ------------------------------------------------------------------------------
>
>                 Key: ISIS-826
>                 URL: https://issues.apache.org/jira/browse/ISIS-826
>             Project: Isis
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: core-1.5.0
>            Reporter: Dan Haywood
>            Priority: Major
>             Fix For: 2.0.0
>
>
> For example, WrappedObject defines save() and wrapped().  If the underlying 
> domain object also defined these methods as actions, then it would be 
> impossible to use the wrapper to check business rules etc.
> Therefore should remove this interface (in Isis 2.x), to replace with one 
> that uses methods which are unlikely to cause a clash.
> (The workaround in the meantime is to rename the action methods and use 
> @Named() if required for the UI).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to