Hi there,

with the recent work around JCR-4025 we have enabled the animal sniffer plugin for trunk, 2.12, 2.10, 2.8, 2.6 (all JDK 6) and 2.4 (JDK 5).


Which leaves us with the question whether we should allow use of JDK 7 in trunk (mapping to Oak trunk which is on JDK 7) and maybe 2.12 (which maps to Oak 1.4 which now is on JDK 7 as well).

So the options are:

1) Leave all at JDK 6.

2) Switch trunk to JDK 7.

3) Switch trunk and 2.12 to JDK 7.

My preference is 2).

Feedback appreciated,

Julian


-------- Forwarded Message --------
Subject: [jira] [Comment Edited] (JCR-4025) Enable animal sniffer plugin
Date: Wed, 21 Sep 2016 13:36:20 +0000 (UTC)
From: Julian Reschke (JIRA) <j...@apache.org>
Reply-To: dev@jackrabbit.apache.org
To: dev@jackrabbit.apache.org


[ https://issues.apache.org/jira/browse/JCR-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15508949#comment-15508949 ]
Julian Reschke edited comment on JCR-4025 at 9/21/16 1:35 PM:
--------------------------------------------------------------

trunk: [r1761679|http://svn.apache.org/r1761679]
2.12: [r1761685|http://svn.apache.org/r1761685]
2.10: [r1761693|http://svn.apache.org/r1761693]
2.8: [r1761701|http://svn.apache.org/r1761701]
2.6: [r1761711|http://svn.apache.org/r1761711]
2.4: [r1761735|http://svn.apache.org/r1761735]


was (Author: reschke):
trunk: [r1761679|http://svn.apache.org/r1761679]
2.12: [r1761685|http://svn.apache.org/r1761685]
2.10: [r1761693|http://svn.apache.org/r1761693]
2.8: [r1761701|http://svn.apache.org/r1761701]
2.6: [r1761711|http://svn.apache.org/r1761711]

Enable animal sniffer plugin
----------------------------

                Key: JCR-4025
                URL: https://issues.apache.org/jira/browse/JCR-4025
            Project: Jackrabbit Content Repository
         Issue Type: Task
         Components: maven
   Affects Versions: 2.4.5, 2.6.6, 2.8.2, 2.12.4, 2.10.4, 2.13.3
           Reporter: Julian Reschke
           Assignee: Julian Reschke
           Priority: Minor
            Fix For: 2.4.7, 2.6.7, 2.10.4, 2.8.3, 2.12.5, 2.13.4

        Attachments: JCR-4025.diff


I would like to use the animal sniffer plugin to enforce usage of the 
advertised minimal Java version. For now, it would check for Java 6, but we 
might align it later on with the related Oak branches.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to