[ 
https://issues.apache.org/jira/browse/JENA-1480?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16358448#comment-16358448
 ] 

Andy Seaborne commented on JENA-1480:
-------------------------------------

I can't reproduce this with the current development snapshot nor with 3.6.0.

BTW there is no Jena 3.7.0 yet. The latest fuseki2 is 3.6.0 - note the align of 
version numbers, so 2.6.0 is not the latest.

I notice that in the description there is a backslash-\{. That would cause a 
400.

I tried, with the current development snapshot, and "count triples in all 
graph" worked for me. This is with a union default graph.

400 errors from Fuseki usually have more details in the body - what does that 
say?


> Bad Request 400 returned when clicking "count triples in all graphs" in 
> Fuseki info
> -----------------------------------------------------------------------------------
>
>                 Key: JENA-1480
>                 URL: https://issues.apache.org/jira/browse/JENA-1480
>             Project: Apache Jena
>          Issue Type: Bug
>          Components: Fuseki
>    Affects Versions: Jena 3.7.0
>            Reporter: David Cook
>            Priority: Minor
>
> When I click "count triples in all graphs", the UI doesn't change and I see 
> the following in the Chrome console:
> {noformat}
> GET 
> <FUSEKI_URL>/query?query=select%20(count(*)%20as%20?count)%20\{?s%20?p%20?o}
> 400 (Bad Request)
> jquery-1.10.2.min.js:6
> {noformat}
> I've experienced this in Fuseki 2.6.0 when using the WAR too. I'm also using 
> the "tdb:unionDefaultGraph true" configuration setting.
> I've used someone else's install of Fuseki 2.5.0 and it works for them. I 
> don't think they're using "tdb:unionDefaultGraph true", and I'm not sure if 
> they're using the WAR or a standalone. Since there is no Server: 
> Apache-Coyote response header, I'm guessing they're using the standalone. I 
> don't know if that would make a difference. 
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to