[ 
https://issues.apache.org/jira/browse/JOSHUA-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15572431#comment-15572431
 ] 

Matt Post commented on JOSHUA-280:
----------------------------------

This is all fixed with the new language packer. Language packs will now include 
the runtime and have no external dependencies (including on Joshua or $JOSHUA).

> Existing Language packs not compatible with Joshua master
> ---------------------------------------------------------
>
>                 Key: JOSHUA-280
>                 URL: https://issues.apache.org/jira/browse/JOSHUA-280
>             Project: Joshua
>          Issue Type: Bug
>          Components: language packs
>    Affects Versions: 6.0.5
>            Reporter: Lewis John McGibbney
>            Assignee: Matt Post
>            Priority: Critical
>             Fix For: 6.1
>
>
> When I work with the existing Spanish --> English language pack at 
> http://cs.jhu.edu/~post/language-packs/language-pack-es-en-phrase-2015-03-06.tgz,
>  I get the following error
> {code}
> lmcgibbn@LMC-032857 
> /usr/local/Cellar/joshua/HEAD/libexec/language-pack-es-en-phrase-2015-03-06(NUTCH-2089)
>  $ ./run-joshua-server.sh
> INFO - Parameters read from configuration file: joshua.config
> INFO -     tm = 'moses -owner pt -maxspan 0 -path phrase-table.packed 
> -max-source-len 5'
> INFO -     defaultnonterminal = 'X'
> INFO -     goalsymbol = 'GOAL'
> INFO -     featurefunction = 'StateMinimizingLanguageModel -lm_type kenlm 
> -lm_order 5 -lm_file lm.kenlm'
> INFO -     markoovs = 'false'
> INFO -     search = 'stack'
> INFO - pop-limit: 100
> INFO -     poplimit = '100'
> INFO -     topn = '0'
> INFO -     useuniquenbest = 'true'
> INFO -     outputformat = '%s'
> INFO -     includealignindex = 'false'
> INFO -     featurefunction = 'OOVPenalty'
> INFO -     featurefunction = 'WordPenalty'
> INFO -     featurefunction = 'Distortion'
> INFO -     featurefunction = 'PhrasePenalty'
> INFO -     c = 'joshua.config'
> INFO -     server-port: 5674
> INFO -     serverport = '5674'
> INFO - Read 9 weights (0 of them dense)
> INFO - Reading vocabulary: phrase-table.packed/vocabulary
> INFO - Read 191983 entries from the vocabulary
> INFO - Reading packed config: phrase-table.packed/config
> ........10........20........30........40........50........60........70........80........90.....100%
> Exception in thread "main" java.lang.RuntimeException: The grammar at 
> phrase-table.packed was packed with packer version 0, but the earliest 
> supported version is 3
>       at 
> org.apache.joshua.decoder.ff.tm.packed.PackedGrammar.readConfig(PackedGrammar.java:1061)
>       at 
> org.apache.joshua.decoder.ff.tm.packed.PackedGrammar.<init>(PackedGrammar.java:143)
>       at 
> org.apache.joshua.decoder.phrase.PhraseTable.<init>(PhraseTable.java:65)
>       at 
> org.apache.joshua.decoder.Decoder.initializeTranslationGrammars(Decoder.java:603)
>       at org.apache.joshua.decoder.Decoder.initialize(Decoder.java:514)
>       at org.apache.joshua.decoder.Decoder.<init>(Decoder.java:126)
>       at org.apache.joshua.decoder.JoshuaDecoder.main(JoshuaDecoder.java:69)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to