[
https://issues.apache.org/jira/browse/KAFKA-696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13561412#comment-13561412
]
Neha Narkhede commented on KAFKA-696:
-------------------------------------
Sorry for a late review. Following are a few review suggestions on patch v2 -
1. FetchRequest
1.1 Remove unused imports "Response" and "BoundedByteBufferSend"
1.2 In the toString() API, for MaxWait, lets append "ms" after the value. Also
for MinBytes, lets append "bytes" after the value
2. KafkaApis
2.1 In handle() APIs, let's move the .format(request.requestObj)) to the
previous line
3. LeaderAndIsrRequest
Let's include "ms" after the value for AckTimeoutMs
4. ProducerRequest
Let's include "ms" after the value for AckTimeoutMs
5. StopReplicaRequest
5.1 Let's include "ms" after the value for AckTimeoutMs
5.2 Looks like we haven't standardized StopReplicaRequest to use
TopicAndPartition instead of a custom Tuple for representing partitions. This
messes up the log4j logging style and the toString() API will not print
partitions the way rest of the code does. You can either include it in your
patch or leave it for KAFKA-649
> Fix toString() API for all requests to make logging easier to read
> ------------------------------------------------------------------
>
> Key: KAFKA-696
> URL: https://issues.apache.org/jira/browse/KAFKA-696
> Project: Kafka
> Issue Type: Bug
> Affects Versions: 0.8
> Reporter: Neha Narkhede
> Assignee: Sriram Subramanian
> Priority: Critical
> Attachments: cleanup-v1.patch, cleanup-v2.patch
>
>
> It will be useful to have consistent logging styles for all requests. Right
> now, we depend on the default toString implementation and the problem is that
> it is very hard to read and prints out unnecessary information like the
> ByteBuffer.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira