Chia-Ping Tsai created KAFKA-19027:
--------------------------------------

             Summary: Replace ConsumerGroupCommandTestUtils#generator by 
ClusterTestDefaults
                 Key: KAFKA-19027
                 URL: https://issues.apache.org/jira/browse/KAFKA-19027
             Project: Kafka
          Issue Type: Improvement
            Reporter: Chia-Ping Tsai
            Assignee: Chia-Ping Tsai


KAFKA-18329 will remove old coordinator, so 
`ConsumerGroupCommandTestUtils#generator` creates only one config now. Hence, 
we should use ClusterTestDefaults to write more readable code for tests. for 
example
{code:java}
@ClusterTestDefaults(
    types = {Type.CO_KRAFT},
    serverProperties = {
        @ClusterConfigProperty(key = OFFSETS_TOPIC_PARTITIONS_CONFIG, value = 
"1"),
        @ClusterConfigProperty(key = OFFSETS_TOPIC_REPLICATION_FACTOR_CONFIG, 
value = "1"),
    }
)
{code}




--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to