[ 
https://issues.apache.org/jira/browse/KAFKA-1481?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14205937#comment-14205937
 ] 

Jun Rao commented on KAFKA-1481:
--------------------------------

[~vladimir.tretyakov], we could probably just add a new MBean to expose the 
Kafka version number. Any value in exposing other things like build hash and 
build timestamp?

Also, could you address my last few comments? For example, it seem #62 is still 
not addressed. A few more comments on the new patch.

64. ConsumerTopicMetrics: Could you merge the following into a single line?
  val tags = metricId
  match {

65. About the change to the aggregate metric name. It seems that we now have 
the following MBean name. A couple of comments on this.
kafka.consumer:type=AggregateFetchRequestAndResponseMetrics,name=FetchRequestRateAndTimeMs,clientId=console-consumer-50964
65.1 We only include the following in KafkaMetricsGroup.consumerMetricNameList. 
That won't match the above aggregate metric's name. So, I am not sure how this 
metric is removed when closing the consumer. The unit test does pass. So, I am 
not sure if it's testing the right thing.
    new MetricName("kafka.consumer", "FetchRequestAndResponseMetrics", 
"FetchResponseSize"),
65.1 I think adding Aggregate in front of the class name is a bit weird. The 
way that we add it in KafkaMetricsGroup is also a bit hacky since it 
essentially changed the typeName for aggregate metrics w/o actually changing 
it. I was thinking for aggregate metrics, would it be simpler just to have the 
following? The fact that it doesn't have any broker level labels is enough an 
indication that it's an aggregate across all brokers.
kafka.consumer:type=FetchRequestAndResponseMetrics,name=FetchRequestRateAndTimeMs,clientId=console-consumer-50964


> Stop using dashes AND underscores as separators in MBean names
> --------------------------------------------------------------
>
>                 Key: KAFKA-1481
>                 URL: https://issues.apache.org/jira/browse/KAFKA-1481
>             Project: Kafka
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.8.1.1
>            Reporter: Otis Gospodnetic
>            Priority: Critical
>              Labels: patch
>             Fix For: 0.8.3
>
>         Attachments: KAFKA-1481_2014-06-06_13-06-35.patch, 
> KAFKA-1481_2014-10-13_18-23-35.patch, KAFKA-1481_2014-10-14_21-53-35.patch, 
> KAFKA-1481_2014-10-15_10-23-35.patch, KAFKA-1481_2014-10-20_23-14-35.patch, 
> KAFKA-1481_2014-10-21_09-14-35.patch, KAFKA-1481_2014-10-30_21-35-43.patch, 
> KAFKA-1481_2014-10-31_14-35-43.patch, 
> KAFKA-1481_2014-11-03_16-39-41_doc.patch, 
> KAFKA-1481_2014-11-03_17-02-23.patch, 
> KAFKA-1481_2014-11-10_20-39-41_doc.patch, 
> KAFKA-1481_2014-11-10_21-02-23.patch, 
> KAFKA-1481_IDEA_IDE_2014-10-14_21-53-35.patch, 
> KAFKA-1481_IDEA_IDE_2014-10-15_10-23-35.patch, 
> KAFKA-1481_IDEA_IDE_2014-10-20_20-14-35.patch, 
> KAFKA-1481_IDEA_IDE_2014-10-20_23-14-35.patch, alternateLayout1.png, 
> alternateLayout2.png, diff-for-alternate-layout1.patch, 
> diff-for-alternate-layout2.patch, originalLayout.png
>
>
> MBeans should not use dashes or underscores as separators because these 
> characters are allowed in hostnames, topics, group and consumer IDs, etc., 
> and these are embedded in MBeans names making it impossible to parse out 
> individual bits from MBeans.
> Perhaps a pipe character should be used to avoid the conflict. 
> This looks like a major blocker because it means nobody can write Kafka 0.8.x 
> monitoring tools unless they are doing it for themselves AND do not use 
> dashes AND do not use underscores.
> See: http://search-hadoop.com/m/4TaT4lonIW



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to