[ https://issues.apache.org/jira/browse/KAFKA-1293?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14375154#comment-14375154 ]
Matt Warhaftig commented on KAFKA-1293: --------------------------------------- In addition to Mirror Maker other tools don't follow argument naming conventions. So, going a step further than the original request I have submitted a patch with updates to: * Standardize tool argument names. * Properly format argument descriptions (into sentences) and add any missing "REQUIRED" notes. * Add 'help' argument to any top-level tool scripts that were missing it. Since argument name changes would have the most impact here is the list: |*Command*|*Old Argument Name*|*New Argument Name*| |kafka-console-consumer.sh|consumer.config|consumer-config| |kafka-consumer-offset-checker.sh|socket.timeout.ms|socket-timeout-ms| |kafka-consumer-offset-checker.sh|retry.backoff.ms|retry-backoff-ms | |ExportZkOffsets.scala|zkconnect|zookeeper| |ImportZkOffsets.scala|zkconnect|zookeeper| |KafkaMigrationTool.java|consumer.config|consumer-config| |KafkaMigrationTool.java|producer.config|producer-config| |KafkaMigrationTool.java|num.producers|num-producers| |KafkaMigrationTool.java|num.streams|num-streams| |KafkaMigrationTool.java|queue.size|queue-size| |kafka-mirror-maker.sh|consumer.config|consumer-config| |kafka-mirror-maker.sh|producer.config|producer-config| |kafka-mirror-maker.sh|num.streams|num-streams| |kafka-producer-perf-test.sh|request-num-acks|request-required-acks| |kafka-replay-log-producer.sh|inputtopic|input-topic| |kafka-replay-log-producer.sh|outputtopic|output-topic| |kafka-replica-verification.sh|topic-white-list|whitelist| |kafka-replica-verification.sh|report-interval-ms|reporting-interval| |kafka-simple-consumer-shell.sh|fetchsize|fetch-size| |TestLogCleaning.scala|zk|zookeeper| |VerifyConsumerRebalance.scala|zookeeper.connect|zookeeper| |TestLinearWriteSpeed.scala|compression|compression-codec| |TestOffsetManager.scala|thread-count|threads| |TestOffsetManager.scala|reporting-interval-ms|reporting-interval| No worries if some of these changes are too dramatic to make it to the codebase. > Mirror maker housecleaning > -------------------------- > > Key: KAFKA-1293 > URL: https://issues.apache.org/jira/browse/KAFKA-1293 > Project: Kafka > Issue Type: Bug > Components: tools > Affects Versions: 0.8.1 > Reporter: Jay Kreps > Priority: Minor > Labels: usability > Attachments: KAFKA-1293.patch > > > Mirror maker uses it's own convention for command-line arguments, e.g. > --num.producers, where everywhere else follows the unix convention like > --num-producers. This is annoying because when running different tools you > have to constantly remember whatever quirks of the person who wrote that tool. > Mirror maker should also have a top-level wrapper script in bin/ to make tab > completion work and so you don't have to remember the fully qualified class > name. -- This message was sent by Atlassian JIRA (v6.3.4#6332)