Mathias Söderberg created KAFKA-2829: ----------------------------------------
Summary: Inconsistent naming in {Producer,Consumer} Callback interfaces Key: KAFKA-2829 URL: https://issues.apache.org/jira/browse/KAFKA-2829 Project: Kafka Issue Type: Bug Components: consumer, producer Affects Versions: 0.9.0.0 Reporter: Mathias Söderberg Assignee: Neha Narkhede Priority: Minor The Callback interface for the "new" producer has a method called "onCompletion" while the OffsetCommitCallback for the new consumer has a method called "onComplete". Perhaps they should be using the same naming convention to avoid confusion? -- This message was sent by Atlassian JIRA (v6.3.4#6332)