KuiLIU created KAFKA-6807:
-----------------------------

             Summary: Inconsistent method name
                 Key: KAFKA-6807
                 URL: https://issues.apache.org/jira/browse/KAFKA-6807
             Project: Kafka
          Issue Type: Improvement
            Reporter: KuiLIU


The following method is named as "readTo", but the method will return the 
variable with lesses value. Thus, the name "readTo" is inconsistent with the 
method body code.
Rename the method as "lesser" should be better.

{code:java}
    private Long readTo(final long endOffset) {
        return endOffset < offsetLimit ? endOffset : offsetLimit;
    }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to