Hi

with old karaf 4.0.10 and our codebase, when we used to compile we were
getting org\springframework folder also in system folder. with latest karaf
and same codebase, it is not getting downloaded.

I am able to generate build with latest karaf but while running, get lot of
osgi wiring exceptions (changing also with each startup attempt)

ex:
caused by: Unable to resolve core-db/1.0.0.SNAPSHOT: missing requirement
[core-db/1.0.0.SNAPSHOT] osgi.wiring.package;
filter:="(osgi.wiring.package=org.springframework.http)
                                                      
resolution:=mandatory [caused by: Unable to resolve
rootwebapp/1.0.0.SNAPSHOT: missing requirement [rootwebapp/1.0.0.SNAPSHOT]
osgi.wiring.package; filter:="(&(osgi.wiring.package=org.springframewo
rk.web.servlet.view)(version>=4.3.7.RELEASE))"]]
                              
resolution:=mandatory [caused by: Unableto resolve
org.apache.commons.pool2/2.0.0: missing requirement
[org.apache.commons.pool2/2.0.0] osgi.wiring.package;
filter:="(osgi.wiring.package=net.sf.cglib.proxy)"]] 

resolution:=mandatory [caused by: Unable to resolve
net.minidev.accessors-smart/1.2.0: missing requirement
[net.minidev.accessors-smart/1.2.0] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.objectweb.asm)(version>=5.0.0)(!(version>=6.0.0)))"]]

Can you please suggest and give some clues to get me in right direction.        
                                                             




--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html

Reply via email to