[ 
https://issues.apache.org/jira/browse/KNOX-756?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15568841#comment-15568841
 ] 

Sandeep More edited comment on KNOX-756 at 10/12/16 2:16 PM:
-------------------------------------------------------------

Patch to update the test dependencies so that the builds do not fail with 
-Prelease profile it contains the following changes:

1) Update apacheds* version to 2.0.0-M15 from gateway-test-release/pom.xml to 
match the main POM
2) Update the 'hadoop-minikdc' version from 2.7.1 to 3.0.0-alpha1, which 
supports apacheds version 2.0.0-M16 (gateway-test-release/pom.xml))
3) Exclude some conflicting dependencies from 'hadoop-minicluster' 
(gateway-test-release/pom.xml))
4) Create a variable for apacheds version in main pom.xml so that it can used 
by other POMs (in this case gateway-test-release/pom.xml)

With this patch all the tests pass when build with 'ant clean release'



was (Author: smore):
Patch to update the test dependencies so that the builds do not fail with 
-Prelease profile it contains the following changes:

1) Update apacheds* version to 2.0.0-M15 from gateway-test-release/pom.xml to 
match the main POM
2) Update the 'hadoop-minikdc' version from 2.7.1 to 3.0.0-alpha1, which 
supports apacheds version 2.0.0-M15 (gateway-test-release/pom.xml))
3) Exclude some conflicting dependencies from 'hadoop-minicluster' 
(gateway-test-release/pom.xml))
4) Create a variable for apacheds version in main pom.xml so that it can used 
by other POMs (in this case gateway-test-release/pom.xml)

With this patch all the tests pass when build with 'ant clean release'


> Build failure with "ant release"
> --------------------------------
>
>                 Key: KNOX-756
>                 URL: https://issues.apache.org/jira/browse/KNOX-756
>             Project: Apache Knox
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 0.10.0
>            Reporter: Sandeep More
>            Assignee: Sandeep More
>              Labels: patch
>             Fix For: 0.10.0
>
>         Attachments: KNOX-756.001.patch
>
>
> With the recent changes, tests for 
> org.apache.hadoop.test.category.ReleaseTest  group are failing. Specifically 
> org.apache.hadoop.gateway.SecureClusterTest.
> To reproduce the problem run Knox build with either of the following commands:
> 1) ant clean release
> 2) mvn  -Ppackage,release  install
> 'mvn  -Ppackage  install' works fine (does not run the ReleaseTest group 
> causing problem)
> A quick look at the dependencies shows that SecureClusterTest is referring to 
> older 'apacheds' release (apacheds-*-2.0.0-M15)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to