[ 
https://issues.apache.org/jira/browse/KNOX-1233?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16430604#comment-16430604
 ] 

ASF subversion and git services commented on KNOX-1233:
-------------------------------------------------------

Commit 2df45990583690fbdf5bc79ee99d9193439185d7 in knox's branch 
refs/heads/master from [~pzampino]
[ https://git-wip-us.apache.org/repos/asf?p=knox.git;h=2df4599 ]

KNOX-1233 - Excluded lang-tag from the pac4j-oidc dependency


> Pac4j dependency causing intermittent compilation errors
> --------------------------------------------------------
>
>                 Key: KNOX-1233
>                 URL: https://issues.apache.org/jira/browse/KNOX-1233
>             Project: Apache Knox
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 1.0.0, 1.1.0
>            Reporter: Phil Zampino
>            Assignee: Phil Zampino
>            Priority: Major
>             Fix For: 1.1.0
>
>
> The transitive com.nimbusds:lang-tag dependency is causing intermittent Knox 
> compilation failures.
> {code:java}
> 09:48:55 2018/03/22 16:48:55 INFO    : [ERROR] Failed to execute goal on 
> project gateway-provider-security-pac4j: Could not resolve dependencies for 
> project 
> org.apache.knox:gateway-provider-security-pac4j:jar:0.12.0.2.6.5.0-191: 
> Failed to collect dependencies at org.pac4j:pac4j-oidc:jar:2.1.0 -> 
> com.nimbusds:oauth2-oidc-sdk:jar:5.24.2 -> 
> com.nimbusds:lang-tag:jar:[1.4.3,): No versions available for 
> com.nimbusds:lang-tag:jar:[1.4.3,) within specified range -> [Help 1]
> {code}
> The range value should be replaced with a single explicit version.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to