Hi Tongxin,

1.5.4 has no special requirement on hive version; From 1.5.3 to 1.5.4, the
kylin.sh has some change, please check whether it was the shell script
which wasn't able to detect the dependency jars correctly. Please share
with us about your finding, or if you can fix that and contribute a patch,
that would be great.



2016-09-19 15:30 GMT+08:00 仇同心 <qiutong...@jd.com>:

> 大家好:
> 今天在使用kylin1.5.4版本时,在同步hive元数据时报错:
> Load Hive Table Metadata From Tree页面一直显示:Loading Databases.
>
>
> 错误信息打印在kylin.out文件
>
> SEVERE: Servlet.service() for servlet [kylin] in context with path
> [/kylin] threw exception [Handler processing failed;
> nested exception is java.lang.NoClassDefFoundError:
> org/apache/hadoop/hive/ql/session/SessionState] with root cause
> java.lang.ClassNotFoundException: org.apache.hadoop.hive.ql.
> session.SessionState
>         at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(
> WebappClassLoaderBase.java:1858)
>         at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(
> WebappClassLoaderBase.java:1701)
>         at org.apache.kylin.rest.controller.TableController.
> showHiveDatabases(TableController.java:315)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(
> NativeMethodAccessorImpl.java:57)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(
> DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:606)
>         at org.springframework.web.method.support.InvocableHandlerMethod.
> doInvoke(InvocableHandlerMethod.java:221)
>         at org.springframework.web.method.support.InvocableHandlerMethod.
> invokeForRequest(InvocableHandlerMethod.java:13
> 6)
>
> 但是hive能正常使用,如果换成kylin 1.5.3版本没问题,Load Hive Table Metadata From
> Tree页面能显示出hive里的db.
> 我使用的hive版本是1.2.1,不知道kylin 1.5.4是否对hive 版本有要求?
>
>
> 谢谢!
>
>


-- 
Best regards,

Shaofeng Shi 史少锋

Reply via email to