[ 
https://issues.apache.org/jira/browse/LENS-1329?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Puneet Gupta resolved LENS-1329.
--------------------------------
       Resolution: Fixed
    Fix Version/s: 2.6

> Validate license for new dependencies
> -------------------------------------
>
>                 Key: LENS-1329
>                 URL: https://issues.apache.org/jira/browse/LENS-1329
>             Project: Apache Lens
>          Issue Type: Sub-task
>          Components: build
>            Reporter: Puneet Gupta
>            Assignee: Puneet Gupta
>             Fix For: 2.6
>
>
> - Run "git diff <last-release-tag> -- pom.xml"
> Example git diff apache-lens-2.5.0-beta -- pom.xml
> - Check the license for new dependencies and make sure its compatible with 
> apache licensing scheme https://www.apache.org/legal/resolved.html
> - If any of the new dependencies added  are not apache licensed, and are 
> getting bundled in binary distribution, LICENSE and NOTICE should be updated 
> in bin-dist-files/



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to