Ok.. To update... I have now uninstalled IIS and re-installed IIS, then coldfusionMX. This seemed to cure like 90% of my woes.
I installed the standalone server, then changed the cacheRealPath option. I have not disabled the built in server as I have not yet found the documentation to move all the admin stuff over to the IIS install. I tried just copying it, and CF failed to start on reboot - so I just moved it back, and all is fine. I ran the IIS connector batch file, and all seems to have installed fine. All mappings, all virtual directories on all domains - so this is great - the furthest I have made it yet. NOW here is what is left for mw to accomplish. For some reason, the default documents are not working (IE - index.cfm) - it just comes up blank. I rename the document to a name like test.cfm and it works fine - both by IP and by domain (using host headers). I was under the impression that this is what changing the cacheRealPath option was supposed to fix? Any ideas? The only other thing I would like to change is all the admin and documentation over to my IIS install from the built-in server - then I can disable it. So any ideas on that too? Thanks in advance for all the help thus far! Dustin On 8/21/02 2:55 AM, "Niklas Richardson" <[EMAIL PROTECTED]> spit this out onto my computer screen: > Getting the jist of what Taz has replied it sounds like you're having > issues with IIS and CFMX. > > It is known that if you install CFMX you should install it under > standalone mode as there is a problem with setting up the connector with > IIS. > > Basically, after installing under standalone mode, to connect to IIS you > run the IIS connector batch file which can be found in > d:\cfusionmx\bin\connectors. Then it should all work fine and dandy. > > Also, after doing that you can turn off the internal webserver by > changing a setting in an XML document. If you want to do that let me > know and i'll get the path for the XML doc. > > However, any changes you make to the internal webserver you have to > reboot the machine, as recycling the CFMX services doesn't recycle the > JRUN service which runs the internal webserver. A bit of pain really, > but easily catches people out! > > Hope that helps. > > Regards > > Niklas > > UK ColdFusion User Group > Chairman > > >> -----Original Message----- >> From: Taz [mailto:[EMAIL PROTECTED]] >> Sent: Tuesday, August 20, 2002 9:41 PM >> To: [EMAIL PROTECTED] >> Subject: Re: [ cf-dev ] List for server admin? WAS: [ cf-dev ] quiet >> >> >> Dustin, >> >> Sorry, I completely missed that one. >> >> Okay, its taken me a while to read through the thread of it, >> and I've had to >> go back over it a couple of times... was suitably impressed with >> >> "THE END >> >> NOVEL WRITTEN BY: Dustin" >> >> Anyway, I'm not an expert but I'm assuming that MX embeds the >> dll mappings >> into IIS the same way as previous versions did... basically >> maping the file >> extensions '.cfm' etc. to CF's dlls. >> Looking at that macromedia documentation, its all command >> prompt work that >> basically does what you can do through IIS. If you open IIS >> and select the >> server, then open the properties window so that you can check the >> application mappings >> >> um... Master Properties (edit): Home Directory tab: Configuration... >> >> Here you can set the dll mappings without having to go >> through all that >> command line shit, which means you can browse for the >> specific dll file... >> so that can't get knacked! >> >> Setting this in the server properties should mean that it's >> set for all >> sites... you might want to check the site folders when you >> test though. >> >> Another thing to check is Services... just to make sure that >> all of the CF >> server services are runnning. Obviously IIS is running okay, >> but perhaps one >> of the CF services is stopping...? (clutching at straws? >> You're damn right!) >> >> If none of the above works... and nobody else on this list >> has contradicted >> what I've said here (I refer back the the point that I've not >> installed MX.. >> I'm still running on 4.5 and 5), then I would suggest that >> you remove CF, >> clean out all of its settings from the registry, uninstall >> IIS, and then >> start from scratch. >> >> Failing that... buy a shotgun and take it out on the server. >> >> Taz >> >>> Ah I asked a big one a few days ago, and there was no >> response.. so I >>> figured no one knew the answer on this list. I have been >> having major >> issues >>> with an install on IIS5 (W2K). I can repost if need be. I >> believe the >>> original email was entitled "errors errors errors". >> >> >> -- >> To unsubscribe, e-mail: [EMAIL PROTECTED] >> For additional commands, e-mail: [EMAIL PROTECTED] >> For human help, e-mail: [EMAIL PROTECTED] >> >> > -- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED] For human help, e-mail: [EMAIL PROTECTED]
