Hi Aaron,

I was able to do some Google searching and came upon this issue 
(https://github.com/depressed-pho/HsOpenSSL/issues/41 
<https://github.com/depressed-pho/HsOpenSSL/issues/41>) in the HsOpenSSL repo. 

I was able to follow the directions from pmer and added the following to my 
stack.yml file:

extra-include-dirs:
- /usr/local/opt/openssl/include
extra-lib-dirs:
- /usr/local/opt/openssl/lib


This all seems to me to be idiosyncratic to my setup, and I believe I can 
remove the changes to stack.yml file after make succeeds. 

- Steven

P.S. make succeeded!!


> On Jul 29, 2017, at 1:15 AM, Aaron Wolf <aa...@snowdrift.coop> wrote:
> 
> On 07/28/2017 03:09 PM, Steven Leiva wrote:
>> Hi Folks, 
>> 
>> I am trying to learn Haskell and looking for a community where I can
>> “learn by doing” so to speak. I would love to get involved with the
>> snowdrift project as it seems like a great fit for that goal.
>> 
> 
> Welcome! I agree, we certainly aim to fit that. We want to make sure we
> live up to that ideal, and we can certainly use the *doing* from
> interested volunteers.
> 
>> Anyway, besides a quick introduction, I’m writing because I am having a
>> bit of trouble building the snowdrift project. 
>> 
>> I am following the instructions in the BUILD.md file
>> (https://git.snowdrift.coop/sd/snowdrift/blob/master/BUILD.md), and I
>> made sure to have *git*, *postgres*, and *stack* installed (ran the
>> which command on all of them to make sure they were in my PATH env). 
>> 
>> Once I cloned the repo and ran *make* in the root directory, I ran into
>> an issue with HsOPENSSL (https://paste.ubuntu.com/25193259/). I didn’t
>> inline this because we al know how unwieldy error messages can be.
>> 
>> I tried following the directions of *brew install openssl*, but when I
>> did so I got this message: *openssl 1.0.2l is already installed*
>> *
>> *
>> The logs of the error can be found here
>> (https://paste.ubuntu.com/25193345/), but they contain the same
>> information as the previous URL.
>> 
>> Thanks for any help folks!
>> 
>> - Steven
>> 
>> P.S. I’m running macOS Sierra 10.12.6
>> 
>> 
> 
> Yeah, the "brew" instruction clued me in earlier to the MacOS bit.
> 
> I suspect this is a MacOS-specific bug in that building is working for
> me on an Ubuntu-based system. Maybe other Mac users on this list can
> reproduce the error?
> 
> Given that this seems possibly related to version issues, I would wonde
> if updating your OS to High Sierra would fix this… if you want to do
> that anyway, maybe it's worth trying. If you have some reason to
> hesitate on that update, then I don't want to push you to it just to
> test this issue.
> 
> Anyone who has further thoughts or insights, please weigh in… I hope we
> can get this fixed and move on to discussing actual Haskell hacking!
> 
> Best,
> Aaron
> 
> _______________________________________________
> Dev mailing list
> Dev@lists.snowdrift.coop
> https://lists.snowdrift.coop/mailman/listinfo/dev

_______________________________________________
Dev mailing list
Dev@lists.snowdrift.coop
https://lists.snowdrift.coop/mailman/listinfo/dev

Reply via email to