Hi Aaron,

I’ll do that during my lunch break!

Thank you. 

- Steven        

> On Aug 8, 2017, at 10:51 AM, Aaron Wolf <aa...@snowdrift.coop> wrote:
> On 08/08/2017 06:00 AM, Steven Leiva wrote:
>> Hi Folks,
>> I am trying to get build the project on my local machine. (I am using
>> macOS). 
>> Unfortunately, when I run *./build.sh test* I get an error that is
>> pointing back to the *hlibsass* library.
>> I think the issue may be fixed if I compile the hlibsass library with
>> the *sharedLibsass* flag, but I do not know how to set that flag in this
>> project.
>> I tried adding the below to snowdrift’s *stack.yaml*, but that led to
>> more cryptic errors that I feel are not going to be productive. 
>> |flags: hlibsass: externalLibsass: true|
>> I wanted to check in with the community in case anyone had any thoughts
>> on this.
>> *Logfile*: 
>> https://paste.ubuntu.com/25269816/
>> *Potentially relevant GitHub Issues*:
>> https://github.com/jakubfijalkowski/hlibsass/issues/1
>> https://github.com/jakubfijalkowski/hsass/issues/4
>> Also, the README of hlibsass has the following text:
>> GHC 7 is unable to load static version of native libraries (at least
>> some of them) and therefore it rejects loading |libsass.a|. On Linux,
>> you can overcome this by switch to GHC 8 (tested with 8.0.2 with LTS
>> Haskell 8.5) or by using shared or external (also shared) version of
>> LibSass. On macOS, GHC 8 still rejects the library (it detects
>> unresolver/duplicated symbols), so the only solution is to use
>> shared/external LibSass (Homebrew version works).
> This sounds like something worth opening an issue about here:
> https://git.snowdrift.coop/sd/snowdrift/issues/
> _______________________________________________
> Dev mailing list
> Dev@lists.snowdrift.coop
> https://lists.snowdrift.coop/mailman/listinfo/dev

Dev mailing list

Reply via email to