[
https://issues.apache.org/jira/browse/LUCENE-5513?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Shai Erera updated LUCENE-5513:
-------------------------------
Attachment: LUCENE-5513.patch
Patch makes the following refactoring changes (all internal API):
* DocValuesUpdate abstract class w/ common implementation for
NumericDocValuesUpdate and BinaryDocValuesUpdate.
* DocValuesFieldUpdates hold the doc+updates for a single field. It mostly
defines the API for the Numeric* and Binary* implementations.
* DocValuesFieldUpdates.Container holds numeric+binary updates for a set of
fields. It is as its name says -- a container of updates used by
ReaderAndUpdates.
** It helps not bloat the API w/ more maps being passed as well as simplified
BufferedUpdatesStream and IndexWriter.commitMergedDeletes.
** It also serves as a factory method based on the updates Type
* Finished TestBinaryDVUpdates
* Added TestMixedDVUpdates which ports some of the 'big' tests from both
TestNDV/BDVUpdates and mixes some NDV and BDV updates.
** I'll beast it some to make sure all edge cases are covered.
I may take a crack at simplifying IW.commitMergedDeletes even more by pulling a
lot of duplicate code into a method. This is impossible now because those
sections modify more than one state variables, but I'll try to stuff these
variables in a container to make this method more sane to read.
Otherwise, I think it's ready.
> Binary DocValues Updates
> ------------------------
>
> Key: LUCENE-5513
> URL: https://issues.apache.org/jira/browse/LUCENE-5513
> Project: Lucene - Core
> Issue Type: Wish
> Components: core/index
> Reporter: Mikhail Khludnev
> Priority: Minor
> Attachments: LUCENE-5513.patch, LUCENE-5513.patch
>
>
> LUCENE-5189 was a great move toward. I wish to continue. The reason for
> having this feature is to have "join-index" - to write children docnums into
> parent's binaryDV. I can try to proceed the implementation, but I'm not so
> experienced in such deep Lucene internals. [~shaie], any hint to begin with
> is much appreciated.
--
This message was sent by Atlassian JIRA
(v6.2#6252)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]