[
https://issues.apache.org/jira/browse/LUCENE-2446?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13955138#comment-13955138
]
Uwe Schindler commented on LUCENE-2446:
---------------------------------------
Great!
I am not so happy about the method name {{validate()}}. Especially as it is in
AtomicReader, people might think (because of name), its just some cheap check.
Yes, I know there are Javadocs, but IDEs suggestions may lead to use it!
I have no yet thought thoroghly about a better name, maybe {{checkIntegrity()}}?
> Add checksums to Lucene segment files
> -------------------------------------
>
> Key: LUCENE-2446
> URL: https://issues.apache.org/jira/browse/LUCENE-2446
> Project: Lucene - Core
> Issue Type: Improvement
> Components: core/index
> Reporter: Lance Norskog
> Labels: checksum
> Attachments: LUCENE-2446.patch
>
>
> It would be useful for the different files in a Lucene index to include
> checksums. This would make it easy to spot corruption while copying index
> files around; the various cloud efforts assume many more data-copying
> operations than older single-index implementations.
> This feature might be much easier to implement if all index files are created
> in a sequential fashion. This issue therefore depends on [LUCENE-2373].
--
This message was sent by Atlassian JIRA
(v6.2#6252)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]