[ 
https://issues.apache.org/jira/browse/SOLR-6022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13984076#comment-13984076
 ] 

Uwe Schindler commented on SOLR-6022:
-------------------------------------

[~tomasflobbe]: The patch for 4.x has to be applied after merge from trunk, so 
first apply patch to trunk, merge that to 4.x and then apply the 4.x patch 
on-top (which restores the deprecated method):

bq. The second patch shows exactly how I will do the deprecation in branch_4x 
(I believe I should be able to just apply the patch after doing a merge back 
from trunk).

> Rename getAnalyzer to getIndexAnalyzer
> --------------------------------------
>
>                 Key: SOLR-6022
>                 URL: https://issues.apache.org/jira/browse/SOLR-6022
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Ryan Ernst
>         Attachments: SOLR-6022.branch_4x-deprecation.patch, SOLR-6022.patch, 
> SOLR-6022.patch
>
>
> We have separate index/query analyzer chains, but the access methods for the 
> analyzers do not match up with the names.  This can lead to unknowingly using 
> the wrong analyzer chain (as it did in SOLR-6017).  We should do this 
> renaming in trunk, and deprecate the old getAnalyzer function in 4x.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to