On Sun, Mar 15, 2015 at 5:03 PM, Nicholas Knize <[email protected]> wrote:
> Had to make a minor change in ES to support this refactor (no biggie).
> Having fresh eyes and curiosity I thought I'd ask what the reason is behind
> this variable name, 'maxDoc', if deletes are not taken into consideration?
> Its a bit of a confusing variable and method name.

You are right: maxDoc is really quite a ridiculous (yet, historical,
legacy, been in Lucene forever) name.  Lucene historically has used
"numDocs" to be number of live docs in the index, and "maxDoc" to be
number of live + deleted (but not yet merged away) docs.

I'm personally API blind to both these names :)

Maybe we should fix it?

Mike McCandless

http://blog.mikemccandless.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to