[
https://issues.apache.org/jira/browse/SOLR-7733?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14661357#comment-14661357
]
Aaron Greenspan commented on SOLR-7733:
---------------------------------------
I would suggest keeping the button but renaming it "Consolidate" or
"Defragment".
Whether or not it technically is, this sounds a lot like the way people used to
think about disk defragmentation on MS-DOS/Windows 3.1/9x systems. Many people
had heard about it almost as a rumor and believed it would serve as a panacea
for all of their deeply-rooted registry problems, when it really only needed to
be done rarely, had minimal benefits for most, and took a long time.
With that context I think the best way to handle it is to keep the button in,
give it a descriptive name, and provide accurate information: something like
"Expected processing time: 30h27m. Expected efficiency gain: 0.05%." No one
will waste their time on such a tradeoff unless they have a really good reason,
or unless the numbers look reasonable.
> remove/rename "optimize" references in the UI.
> ----------------------------------------------
>
> Key: SOLR-7733
> URL: https://issues.apache.org/jira/browse/SOLR-7733
> Project: Solr
> Issue Type: Improvement
> Components: UI
> Affects Versions: 5.3, Trunk
> Reporter: Erick Erickson
> Assignee: Upayavira
> Priority: Minor
> Attachments: SOLR-7733.patch
>
>
> Since optimizing indexes is kind of a special circumstance thing, what do we
> think about removing (or renaming) optimize-related stuff on the core admin
> and core overview pages? The "optimize" button is already gone from the core
> admin screen (was this intentional?).
> My personal feeling is that we should remove this entirely as it's too easy
> to think "Of course I want my index optimized" and "look, this screen says my
> index isn't optimized, that must mean I should optimize it".
> The core admin screen and the core overview page both have an "optimized"
> checkmark, I propose just removing it from the "overview" page and on the
> "core admin" page changing it to "Segment Count #". NOTE: the "overview" page
> already has a "Segment Count" entry.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]