Michael McCandless commented on LUCENE-7494:

{{Fields}} does seem a bit silly, being such a tiny wrapper class, and it would 
make things more consistent if you also just passed a field name to the 
IndexReader API.

Though, we also return {{Fields}} from {{getTermVectors}}, since that's 
essentially a tiny single-document inverted index.  I'm not sure how we'd 
polish that usage away ... I guess we could just narrow it to a new (old!) 
{{TermVectors}} class.

> Explore making PointValues a per-field API like doc values
> ----------------------------------------------------------
>                 Key: LUCENE-7494
>                 URL: https://issues.apache.org/jira/browse/LUCENE-7494
>             Project: Lucene - Core
>          Issue Type: Wish
>            Reporter: Adrien Grand
>            Priority: Minor
> This is a follow-up to LUCENE-7491. Maybe we could simplify things a bit by 
> changing {{LeafReader.getPointValues()}} to 
> {{LeafReader.getPointValues(String fieldName)}} and removing all {{String 
> fieldName}} parameters from {{PointValues}}?

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to