Hi,

> > +    this.indexSortFields = Arrays.stream(sort.getSort()).map((s) ->
> > s.getField()).collect(Collectors.toSet());
> 
> I'd use method references instead of Lambdas:
> 
> Instead of: map((s) -> s.getField())
> Use: map(s::getField)

Correction: map(SortField::getField)

> This spares a synthetic lambda$xxx method that clutters stack trace and is
> more readable.
> 
> Uwe
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
> For additional commands, e-mail: dev-h...@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to