[ 
https://issues.apache.org/jira/browse/SOLR-11181?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16120515#comment-16120515
 ] 

Steve Rowe commented on SOLR-11181:
-----------------------------------

[~lmonson], I ran the following with your patch applied to upload 8.0-SNAPSHOT 
artifacts to the Apache Snapshot Repository.

{noformat}
ant -Dm2.repository.id=apache.snapshots.https 
-Dm2.repository.url=https://repository.apache.org/content/repositories/snapshots
 generate-maven-artifacts
{noformat}

You can see the result for {{lucene-core}} here (artifacts share the infix 
{{-8.0.0-20170809.185958-28.}}): 
https://repository.apache.org/content/repositories/snapshots/org/apache/lucene/lucene-core/8.0.0-SNAPSHOT/

Unlike all previous runs, neither {{-sources}} nor {{-javadoc}} artifacts were 
uploaded when I used your patch.  This is not acceptable.  When you run with 
your patch, do these artifacts get uploaded?

Next I'll try to reproduce the problem you're trying to solve with the 
unpatched build.


> Deploying Maven artifacts (generate-maven-artifacts) pushes the same 
> artifacts multiple times
> ---------------------------------------------------------------------------------------------
>
>                 Key: SOLR-11181
>                 URL: https://issues.apache.org/jira/browse/SOLR-11181
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: Build
>    Affects Versions: 6.6, master (8.0), 7.1
>            Reporter: Lynn Monson
>            Assignee: Steve Rowe
>            Priority: Minor
>         Attachments: SOLR-11181.patch
>
>
> When following the instructions in the README.maven file, and watching the 
> wire traffic, the build system issues HTTP PUT operations for the same 
> artifacts multiple times.   For example, issuing this command:
>       ant -Dm2.repository.id=my-repo-id \
>           -Dm2.repository.url=http://example.org/my/repo \
>           generate-maven-artifacts
> from the lucene/ directory will generate redundant puts.  For example:
> PUT 
> /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar
>  
> PUT 
> /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar.sha1
>  
> PUT 
> /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar.md5
> ...
> PUT 
> /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar
>  
> ...
> The maven repo I am using does not allow the second PUT and, hence, the build 
> fails.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to